Contents

ohjnewtopic=OWM0010=endtopic

Welcome to the Oracle Wallet Manager help system. The help topics are grouped into the following three help books. Click on a help book title below to view that help book.

Overview

Managing Wallets

Operations


Overview

ohjnewtopic=OWM0012=endtopic

Refer to the sections listed below for an introduction to Oracle Wallet Manager and an overview of the security principles incorporated into the design of this product.

Introduction

Security Concepts


Introduction

ohjnewtopic=OWM0015=endtopic

Oracle Wallet Manager v2.1 is a Java-based application security administrators use to manage public-key security credentials on clients and on servers. Public-key cryptography requires that parties who want to communicate in a secure manner possess certain security credentials. This collection of security credentials is stored in a wallet. An Oracle wallet is an abstraction used to store and manage security credentials for clients and servers.

Security credentials consist of a public/private key pair, a certificate, and trusted certificates. Each entity that participates in a public key system must own a public/private key pair. The public key for the entity is published, so that other entities that want to send it secure information can encrypt that information with the recipient entity's public key. The Oracle Wallet Manager is used to administer wallets, generate public/private key pairs for clients and servers, and administer certificates.


Security Concepts

ohjnewtopic=OWM0017=endtopic

Following is a list of general security concepts and their associated definitions that you need to know.

Concept Name | Definition
Authentication | The recipient of an authenticated message can be certain of the message's origin (its sender). Authentication reduces the possibility that another person has impersonated the sender of the message.
Authorization | The set of privileges available to an authenticated entity.
Certificate | A certificate is created when an entity's public key is signed by a trusted identity: a certificate authority. The certificate ensures that the entity's information is correct and that the public key actually belongs to that entity.
Certificate Authority | An application that creates public key certificates.
Confidentiality | A function of cryptography. Confidentiality guarantees that only the intended recipient(s) of a message can view the message (decrypt the ciphertext).
Cryptography | The act of writing and deciphering secret code resulting in secure messages.
Decryption | The process of converting the contents of an encrypted message (ciphertext) back into its original readable format (plaintext).
Digital Signature | A digital signature is created when a public key algorithm is used to sign the sender's message with the sender's private key. The digital signature assures that the document is authentic, has not been forged by another entity, has not been altered, and cannot be repudiated by the sender.
Encryption | The process of disguising the contents of a message and rendering it unreadable (ciphertext) to anyone but the intended recipient.
Identity | A user who is typically certified.
Integrity | The guarantee that the contents of the message received were not altered from the contents of the original message sent.
Non-repudiation | Undeniable proof of the origin, delivery, submission, or transmission of a message.
Public-Key Encryption | The process where the sender of a message encrypts the message with the public key of the recipient. Upon delivery, the message is decrypted by the recipient using the recipient's private key.
Public/Private Key Pair | A mathematically related set of two numbers where one is called the private key and the other is called the public key. Public keys are typically made widely available, while a private key is available only to the owner. Data encrypted with a public key can only be decrypted with its corresponding private key and vice versa. However, data encrypted with a public key cannot be decrypted with the same public key.
Trusted Certificate | A trusted certificate is a third party identity that is qualified with a level of trust. The trusted certificate is used when an identity is being validated as the entity it claims to be. The certificate authorities you trust are the issuers of trusted certificates.
Wallet | A wallet is an abstraction used to store and manage security credentials for an individual entity. It implements the storage and retrieval of credentials for use with various cryptographic services. A wallet resource locator (WRL) provides all the necessary information to locate the wallet.
Wallet Resource Locator | A directory path that provides all the necessary information to locate a particular wallet.
WRL | See Wallet Resource Locator.
X.509 | The public keys can be signed in various data formats. The X.509 format from ISO is one such popular format.


Managing Wallets

ohjnewtopic=OWM0020=endtopic

Use Oracle Wallet Manager to perform the following wallet management tasks.

Create a New Wallet

Open an Existing Wallet

Close an Open Wallet

Save (Wallet)

Save As...

Save in System Default

Change a Wallet Password

Select Auto Login


Create a New Wallet

ohjnewtopic=OWM0030=endtopic

Create a new wallet as follows:

  1. Click Wallet > New from the menu bar.

  2. The New Wallet dialog box appears.

  3. Type a new password in the Wallet Password field.

  4. Retype the new password in the Confirm Password field.

  5. Click OK.

  6. A dialog box displays to inform you that a new empty wallet was created and to prompt you to decide whether you want to create a certificate request for the new wallet.

  7. Click OK.

  8. The Create Certificate Request dialog box appears. Type the information listed below in the fields contained in the dialog box, or click Advanced to create a customized identity.

  9. Type the entity's common name.

  10. Type the name of the company's organizational unit.

  11. Type the name of the organization.

  12. Click the drop down list to select the country in which the entity exists.

  13. Click the drop down list to select the key size to be used to generate the public/private key pair.

  14. Click OK to continue.

  15. A dialog box displays to inform you that the certificate request was created. It also displays the certificate request text.

  16. Click OK.

Your new wallet will contain a certificate that has a status of Requested.


Open an Existing Wallet

ohjnewtopic=OWM0040=endtopic

Open a wallet as follows:

  1. Click Wallet > Open from the menu bar.

  2. The Select Directory dialog box appears.

  3. Scroll the directory tree to find the wallet location.

  4. Click to select the wallet location.

  5. Click OK.

  6. The Open Wallet password dialog box appears.

  7. Type the wallet password, and click OK.

  8. A dialog box displays to inform you that the wallet was successfully opened, otherwise a dialog box appears if you typed an incorrect password. In this case, click OK, and begin with step 1.

The open wallet is displayed in the directory tree when it is successfully opened.


Close an Open Wallet

ohjnewtopic=OWM0050=endtopic

Close an open wallet as follows:

  1. Click Wallet > Close from the menu bar.

  2. A dialog box displays to inform you that the current wallet is closed.

  3. Click OK to dismiss the dialog box.


Save (Wallet)

ohjnewtopic=OWM0065=endtopic

  1. Click Wallet > Save to save an updated wallet to the directory from which it was opened.

  2. A dialog box appears and informs you that the wallet was successfully saved in the directory location.

  3. Click OK to dismiss the dialog box.

Note:

This save function will behave exactly like Wallet > Save As when you first save a new wallet. Refer to Save As... .


Save As...

ohjnewtopic=OWM0070=endtopic

Save the current open wallet to another file location as follows:

  1. Click Wallet > Save As.

  2. The Select Directory dialog box appears.

  3. Scroll the directory tree to find the location in which you want to store the new copy of the wallet.

  4. Click OK.

  5. A dialog box displays to inform you that the wallet was successfully saved in the new directory location.

  6. Click OK to dismiss the dialog box.


Save in System Default

ohjnewtopic=OWM0060=endtopic

Save an open wallet to the system defined default location as follows.

  1. Click Wallet > Save in System Default.

  2. A dialog box displays the following message.

Wallet saved successfully in system default location.

3. Click OK to dismiss the dialog box.


Change a Wallet Password

ohjnewtopic=OWM0080=endtopic

Change the password of an open wallet as follows:

  1. Click Wallet > Change Password.

  2. The Change Wallet Password dialog box appears.

  3. Type the current password in the Old Wallet Password field.

  4. Type the new password in the New Wallet Password field.

  5. Type the new wallet password again for verification in the Confirm Wallet Password field.

  6. Click OK.

  7. A dialog box displays to inform you that the wallet password has successfully been changed.

  8. Click OK.


Select Auto Login

ohjnewtopic=OWM0090=endtopic

Use the Auto Login feature of the Oracle Wallet Manager to enable the automatic log on of applications to the Oracle server: This removes the need to provide a password each time an application accesses an Oracle server. Set the wallet auto login state as follows:

  1. Open the desired wallet.

  2. Click the Wallet drop down list.

  3. Click the Auto Login check box to enable or disable automatic login of applications.

  4. A dialog box appears to inform you that automatic login is enabled or disabled.

  5. Click OK.

Note:

Use Auto Login for wallets stored in the default wallet location.


Advanced

ohjnewtopic=OWM0180=endtopic

Click the Advanced button in the Create Certificate Request dialog box to create a custom identity for your new wallet. Create an advanced certificate request as follows:

  1. Click Advanced.
    The Advanced Certificate Request dialog box appears.

  2. Type the distinguished name of the entity for which you are creating a wallet.

  3. Click OK when you are finished.

The Create Certificate Request dialog box appears.

4. Review the certificate request information, and click OK.

5. Send the certificate request to a certificate authority.

6. Install the certificate you receive from the certificate authority. See Import a User Certificate.


Operations

ohjnewtopic=OWM0100=endtopic

Use the Oracle Wallet Manager to perform the following tasks:

Create a Certificate Request

Import a User Certificate

Import a Trusted Certificate

Remove a Trusted Certificate

Export a User Certificate

Export a User Certificate Request

Export a Trusted Certificate

Export All Trusted Certificates

Export Wallet


Create a Certificate Request

ohjnewtopic=OWM0110=endtopic

Refer to Create a New Wallet for instructions on how to generate a certificate request.


Import a User Certificate

ohjnewtopic=OWM0120=endtopic

You can import a user certificate into a wallet by either pasting the certificate into the wallet or by selecting a file that contains the certificate. In either case, you first need to verify that the certificate authority that signed the user certificate is installed as a trusted certificate. See Import a Trusted Certificate .

Paste a user certificate into a wallet as follows:

  1. Click Operations > Import User Certificate. The Import Certificate dialog box displays.

  2. Click the Paste the certificate radio button.

  3. Click OK. The Import Certificate dialog box displays.

  4. Copy the certificate text from its source.

  5. Paste the certificate text into the body of the dialog box.

  6. Click OK.

  7. A dialog box informs you that the certificate was successfully installed in the wallet.

Import a user certificate from a file into a wallet as follows:

  1. Click Operations > Import User Certificate. The Import Certificate dialog box displays.

  2. Click Select a file that contains the certificate.

  3. Click OK. The Import Certificate dialog box displays.

  4. Click to select the file that contains the certificate.

  5. Click OK.

  6. A dialog box informs you that the certificate was successfully installed in the wallet.


Import a Trusted Certificate

ohjnewtopic=OWM0130=endtopic

You can import a trusted certificate into a wallet by either pasting the certificate into the wallet or by selecting a file that contains the certificate.

Paste a trusted certificate into a wallet as follows:

  1. Click Operations > Import Trusted Certificate. The Import Trusted Certificate dialog box displays.

  2. Click the Paste the certificate radio button.

  3. Click OK. The Import Trusted Certificate dialog box displays.

  4. Copy the certificate text from its source.

  5. Paste the certificate text into the body of the dialog box.

  6. Click OK.

  7. A dialog box informs you that the trusted certificate was successfully installed in the wallet.

Import a trusted certificate from a file into a wallet as follows:

  1. Click Operations > Import Trusted Certificate. The Import Trusted Certificate dialog box displays.

  2. Click Select a file that contains the certificate.

  3. Click OK. The Import Trusted Certificate dialog box displays.

  4. Click to select the file that contains the certificate.

  5. Click OK.

  6. A dialog box informs you that the trusted certificate was successfully installed in the wallet.


Remove a Trusted Certificate

ohjnewtopic=OWM0140=endtopic

Remove a trusted certificate as follows:

  1. Click to expand the Trusted Certificates node of the properties tree.

  2. Scan the list of trusted certificates, and click to select the one you want to remove from the wallet.

  3. Click Operations > Remove Trusted Certificate.

  4. A dialog box displays to warn you that certificates signed with the selected trusted certificate will no longer be verifiable.

  5. Click OK to continue.

  6. The selected trusted certificate is removed from the wallet.


Export a User Certificate

ohjnewtopic=OWM0150=endtopic

Oracle Wallet Manager gives you the ability to use an existing user certificate in more than one wallet. You can export a user certificate into the directory of another wallet. Export a user certificate as follows:

  1. Click Operations > Export User Certificate. The Export User Certificate dialog box displays.

  2. Type the file system directory location of where you want to copy the user certificate, or click Browse to scroll the directory.

  3. The user certificate file name appears in the Enter File Name field.

  4. Type the name of the file that you want the trusted certificate to be saved as.

  5. Click OK.

  6. A dialog box displays the message "User Certificate export successful".

  7. Click OK to dismiss this dialog box.


Export a User Certificate Request

ohjnewtopic=OWM0160=endtopic

Export a user certificate request as follows:

  1. Click Operations > Export Certificate Request. The Export Certificate Request dialog box displays.

  2. Type the file system directory location of where you want to copy the user certificate, or click Browse to scroll the directory.

  3. The user certificate file name appears in the Enter File Name field.

  4. Type the name of the file that you want the certificate request to be saved as.

  5. Click OK.

  6. A dialog box displays the message "Certificate request export successful".

  7. Click OK to dismiss this dialog box.


Export a Trusted Certificate

ohjnewtopic=OWM0170=endtopic

Oracle Wallet Manager gives you the ability to use an existing trusted certificate in more than one wallet. You can export a trusted certificate into the directory of another wallet. Export a trusted certificate as follows:

  1. Click Operations > Export Trusted Certificate. The Export Trusted Certificate dialog box displays.

  2. Type the file system directory location of where you want to copy the trusted certificate, or click Browse to scroll the directory.

  3. The trusted certificate file name appears in the Enter File Name field.

  4. Type the name of the file that you want the trusted certificate to be saved as.

  5. Click OK.

  6. A dialog box displays the message "Trusted Certificate export successful".

  7. Click OK to dismiss this dialog box.


Export All Trusted Certificates

ohjnewtopic=OWM0174=endtopic

Oracle Wallet Manager gives you the ability to export all trusted certificates (in base 64 format) from the current open wallet to a single file. Each trusted certificate in this file is preceded by the following information: Subject Name, Issuer Name, Expiration Date, and the actual certificate text encoded in base64 format. You can then copy this file into the directory of another wallet. Export All Trusted Certificates as follows:

  1. Click Operations > Export All Trusted Certificates. The Export Trusted Certificate dialog box displays.

  2. Type the file system directory location into which you want to copy the trusted certificate, or click Browse to scroll the directory.

  3. Type the name of the file to which you want the trusted certificates to be saved in the Enter File Name field.

  4. Click OK.

  5. A dialog box displays the message "Trusted Certificate export successful".

  6. Click OK to dismiss this dialog box.


Export Wallet

ohjnewtopic=OWM0178=endtopic

Oracle Wallet Manager gives you the ability to export the current, open wallet to another file system location. You can only export wallets whose status is Ready. The wallet you export will contain the user certificate text encoded in base64 format, the encrypted private key, and all trusted certificates. The password for the private key becomes the password for the open wallet. Export a Wallet as follows:

  1. Click Operations > Export Wallet. The Export Wallet dialog box displays.

  2. Type the file system directory location into which you want to copy the wallet, or click Browse to scroll the directory.

  3. Type the name of the file to which you want the wallet to be saved in the Enter File Name field.

  4. Click OK.

  5. A dialog box displays the message "Wallet export successful".

  6. Click OK to dismiss this dialog box.